Python Version Mismatch

A small problem that probably doesn’t matter, but it generates an error message in the httpd log files, so it is bothersome.  The error is something like "Python version mismatch, expected '2.6' found '2.6.4'.  The last version number doesn’t matter.  It will likely be something other than 2.6.4.  The important thing is that it is different from 2.6, which is the version of Python compiled with Fedora 13.  So how do we get rid of the pesky error?  Well, here is one way.

Replace the mod_python that comes with Fedora with a “rebuilt” version.  The commands are listed below, but if you are like me you may have to download some dependencies first. 

yumdownloader --source mod_python
rpmbuild --rebuild mod_python-3.3.1-11.src.rpm
rpm -e mod_python
rpm-Uvh mod_python-3.3.1-11.src.rpm

What we are doing her is compiling another version of mod_python from the sourcerpm and then putting it in place of the one that is generating the error.

Comments are closed.